Pouzivam toto, ale je potreba si pripadne upravit delay, ja to mam pro jistotu aby to vzdy proslo ale trva to dlouho, ale nevadi.
:local server
:local user
:local password
:local mode
:local year
:local month
:local newmonthnum
:local day
:local time
:local identity
:local dstpath
:set identity [/system identity get name]
:set server 10.0.6.1
:set user mikrotik-backup
:set password 1234
:set mode ftp
:set dstpath BACKUP-MIKROTIK
:set year [:pick [/system clock get date] 7 11]
:set month [:pick [/system clock get date] 0 3]
:if ($month = "jan") do={ :set newmonthnum 01 }
:if ($month = "feb") do={ :set newmonthnum 02 }
:if ($month = "mar") do={ :set newmonthnum 03 }
:if ($month = "apr") do={ :set newmonthnum 04 }
:if ($month = "may") do={ :set newmonthnum 05 }
:if ($month = "jun") do={ :set newmonthnum 06 }
:if ($month = "jul") do={ :set newmonthnum 07 }
:if ($month = "aug") do={ :set newmonthnum 08 }
:if ($month = "sep") do={ :set newmonthnum 09 }
:if ($month = "oct") do={ :set newmonthnum 10 }
:if ($month = "nov") do={ :set newmonthnum 11 }
:if ($month = "dec") do={ :set newmonthnum 12 }
:set day [:pick [/system clock get date] 4 6]
:set time [/system clock get time]
/export compact file="$identity on $year_$newmonthnum_$day at $time_EC"
/export compact file="$identity on $year_$newmonthnum_$day at $time_EF"
/system backup save name="$identity on $year_$newmonthnum_$day at $time_B"
:delay 300
/tool fetch address=$server src-path="$identity on $year_$newmonthnum_$day at $time_EC.rsc" dst-path="$dstpath/$identity on $year_$newmonthnum_$day at $time_EC.rsc" user=$user password=$password upload=yes mode=$mode
/tool fetch address=$server src-path="$identity on $year_$newmonthnum_$day at $time_EF.rsc" dst-path="$dstpath/$identity on $year_$newmonthnum_$day at $time_EF.rsc" user=$user password=$password upload=yes mode=$mode
/tool fetch address=$server src-path="$identity on $year_$newmonthnum_$day at $time_B.backup" dst-path="$dstpath/$identity on $year_$newmonthnum_$day at $time_B.backup" user=$user password=$password upload=yes mode=$mode
:delay 300
/file remove "$identity on $year_$newmonthnum_$day at $time_EF.rsc"
/file remove "$identity on $year_$newmonthnum_$day at $time_EC.rsc"
/file remove "$identity on $year_$newmonthnum_$day at $time_B.backup"