martas Stále to studuji, takže doplním - v jednom videu říkali, že bridge zpracuje každý paket nezávisle na tagu. Tohle vědět hnedle na začátku, tak jsem si ušetřil spoustu přemýšlení. Nakonec je to velice jednoduché.
mirmo80 Jasné, rád pomůžu. Kdyby jsi měl dotazy, klidně se ptej. Osekal jsem o nepotřebná nastavení, nechal jsem tam CAPsMANa:
/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz name=2G reselect-interval=30m
add band=5ghz-a/n/ac control-channel-width=20mhz name=5G reselect-interval=\
30m skip-dfs-channels=yes
/caps-man datapath
add local-forwarding=yes name=lan
add local-forwarding=yes name=guest vlan-id=2 vlan-mode=use-tag
add client-to-client-forwarding=yes local-forwarding=yes name=2Patro vlan-id=\
30 vlan-mode=use-tag
add client-to-client-forwarding=yes local-forwarding=yes name=Sklep vlan-id=\
40 vlan-mode=use-tag
/interface bridge
add admin-mac=74:4D:28:A1:3B:A5 arp=proxy-arp auto-mac=no name=br1_1Patro
add name=br2_2Patro
add name=br3_Sklep
/interface ethernet
set [ find default-name=ether1 ] name=eth1_WAN speed=100Mbps
set [ find default-name=ether2 ] name=eth2_LAN_1Patro speed=100Mbps
set [ find default-name=ether3 ] name=eth3_LAN_2Patro speed=100Mbps
set [ find default-name=ether4 ] name=eth4_LAN_Sklep speed=100Mbps
set [ find default-name=ether5 ] name=eth5_LAN_slave speed=100Mbps
set [ find default-name=ether6 ] name=eth6_LAN_slave speed=100Mbps
set [ find default-name=ether7 ] name=eth7_LAN_slave speed=100Mbps
set [ find default-name=ether8 ] name=eth8_LAN_slave speed=100Mbps
set [ find default-name=ether9 ] name=eth9_LAN_slave speed=100Mbps
set [ find default-name=ether10 ] name=eth10_LAN_AP speed=100Mbps
set [ find default-name=sfp1 ] advertise=\
10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
/interface vlan
add interface=br1_1Patro name=vlan2_GUEST vlan-id=2
add interface=br1_1Patro name=vlan30_2Patro vlan-id=30
add interface=br1_1Patro name=vlan40_Sklep vlan-id=40
/caps-man rates
add basic=12Mbps name=min_12mbps supported=\
12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm name=1Patro-guest
add authentication-types=wpa2-psk encryption=aes-ccm name=1Patro
add authentication-types=wpa2-psk encryption=aes-ccm name=2Patro
add authentication-types=wpa2-psk encryption=aes-ccm name=Sklep
/caps-man configuration
add channel=2G country="czech republic" datapath=lan disconnect-timeout=10s \
distance=indoors installation=indoor max-sta-count=20 mode=ap name=lan2G \
rates=min_12mbps security=1Patro ssid=1Patro
add channel=5G country="czech republic" datapath=lan disconnect-timeout=10s \
distance=indoors installation=indoor max-sta-count=20 mode=ap name=lan5G \
rates=min_12mbps security=1Patro ssid=1Patro
add datapath=guest mode=ap name=guest rates=min_12mbps security=1Patro-guest \
ssid="1Patro Guest"
add datapath=2Patro mode=ap name=2Patro rates=min_12mbps security=2Patro \
ssid=Kresla
add datapath=Sklep mode=ap name=Sklep rates=min_12mbps security=Sklep ssid=\
Sklep
/ip pool
add name=dhcp ranges=192.168.123.101-192.168.123.199
add name=pool_GUEST ranges=192.168.124.101-192.168.124.199
add name=pool_2Patro ranges=192.168.130.100-192.168.130.199
add name=pool_Sklep ranges=192.168.140.100-192.168.140.199
/ip dhcp-server
add address-pool=dhcp disabled=no interface=br1_1Patro name=dhcp_LAN
add address-pool=pool_GUEST disabled=no interface=vlan2_GUEST name=dhcp_GUEST
add address-pool=pool_2Patro disabled=no interface=br2_2Patro name=\
dhcp_2Patro
add address-pool=pool_Sklep disabled=no interface=br3_Sklep name=dhcp_Sklep
/caps-man manager
set enabled=yes upgrade-policy=require-same-version
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=br1_1Patro
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=\
lan2G name-format=prefix-identity name-prefix=2G slave-configurations=\
guest,2Patro,Sklep
add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=\
lan5G name-format=prefix-identity name-prefix=5G slave-configurations=\
guest,2Patro,Sklep
/interface bridge port
add bridge=br1_1Patro comment=defconf interface=eth2_LAN_1Patro
add bridge=br1_1Patro comment=defconf interface=eth5_LAN_slave
add bridge=br1_1Patro comment=defconf interface=eth6_LAN_slave
add bridge=br1_1Patro comment=defconf interface=eth7_LAN_slave
add bridge=br1_1Patro comment=defconf interface=eth8_LAN_slave
add bridge=br1_1Patro comment=defconf interface=eth9_LAN_slave
add bridge=br1_1Patro comment=defconf interface=eth10_LAN_AP
add bridge=br1_1Patro comment=defconf interface=sfp1
add bridge=br3_Sklep comment=defconf interface=eth4_LAN_Sklep
add bridge=br2_2Patro comment=defconf interface=eth3_LAN_2Patro
add bridge=br2_2Patro interface=vlan30_2Patro
add bridge=br3_Sklep interface=vlan40_Sklep
/ip address
add address=192.168.123.1/24 interface=eth2_LAN_1Patro network=192.168.123.0
add address=192.168.124.1/24 interface=vlan2_GUEST network=192.168.124.0
add address=192.168.130.1/24 interface=br2_2Patro network=192.168.130.0
add address=192.168.140.1/24 interface=br3_Sklep network=192.168.140.0
/ip dhcp-server network
add address=192.168.123.0/24 dns-server=192.168.123.1 gateway=192.168.123.1 \
ntp-server=192.168.123.1
add address=192.168.124.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.124.1
add address=192.168.130.0/24 gateway=192.168.130.1
add address=192.168.140.0/24 gateway=192.168.140.1